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Overview

 Shuttle software description

 Main functions

 System main interface

 System operating environment

CHAPTER1



Shuttle software description

Shuttle is a high-precision GNSS/INS positioning and attitude

determination post-processing software, independently developed by

Wuhan Geosun Navigation Technology Co., Ltd., built-in high precision

GPS/GLONASS/Beidou II/Galileo positioning velocity measurement

processor (GGPoS). The system can process multi-mode GNSS

positioning velocity measurement, GNSS/INS combined positioning

attitude measurement, providing centimeter-level spatial position

information of motion point (or carrier), centimeter-level speed

information, and thousand-degree attitude information.

Shuttle adopts the world's leading single epoch ambiguity algorithm

and high-order Kalman filter to maximize integrate the GNSS carrier

phase and inertial navigation component (IMU) information.

Compared to GNSS post-processing, GNSS/INS combination provides

richer carrier dynamic information, higher resolution accuracy and

reliability. Shuttle is compatible with both incremental and rate type

IMU data, providing a rich IMU random error model, having processing

capability with various accuracy levels of IMU data. It surpasses

international similar software in many aspects and provides better

choices for users, especially Chinese users.

Shuttle is widely used in aerial photogrammetry, urban mobile

measurement and other high-precision positioning attitudes, such as

railways, urban transportation, and aerospace vehicles. In addition,

Shuttle is based on a component-based model with good scalability

and even a flexible product range.

Main function

Shuttle's high-precision positioning and attitude measurement

post-processing software provides information of position, velocity
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and attitude of the carrier. The main functions includes:

GNSS high precision differential positioning velocity measurement

Differential positioning is performed by using more than two types of

GPS/BDS/GLONASS receivers. It is characterized by providing more

accurate position information that eliminates common errors and

overcomes the shortcomings of single point positioning errors. The

system data structure is based on single-frequency, dual-frequency

C/A code, P code, carrier phase and Doppler shift observations. It can

not only solve single-frequency and dual-frequency data, but also

receive Galileo system data, and provide important reliability

guarantees without changing any system framework. Differential

speed measurement accuracy ups to 0.05 m / s.

GNSS/INS high-precision combined positioning and attitude

measurement

The GNSS/INS combination is solved by using GNSS data, three-axis

gyro and three-axis accelerometer data. The GNSS provides absolute

position information, three-axis gyro and three-axis accelerometer

data are integrated to obtain attitude angle and relative position

information. The sensor error and the integral cumulative error are

corrected by the GNSS through the Kalman filter. Inertial navigation

calculations are performed in the Earth's Fixed Coordinate System

(ECEF) for tight integration with GNSS, while supporting zero speed

update (ZUPT), forward and reverse round-trip filtering, smoothing,

and odometer and total station auxiliary calculation, continuous

high-precision positioning even during GNSS loss of lock.

INS initial alignment
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Process of coarse alignment, fine alignment, and dynamic correction.

The coarse alignment quickly obtains the orientation information of

the carrier relative to the navigation system under the static condition

by using the gravity acceleration and the earth rotation angular rate;

the fine alignment is still under static conditions, and the zero velocity

is used as the external observation, which can further improve the

attitude accuracy and estimate the gyro Zero offset; dynamic

correction separates the attitude error from the accelerometer by the

dynamic maneuver of the carrier and the GNSS positioning

information.

INS high order error model

The INS error is consisted of deterministic error and random process

error. There are dozens of error types. Shuttle comprehensively

considers sensor accuracy, error identifiability and software stability to

establish position, velocity, attitude and gyro bias, accelerometer zero

offset, gyro scale factor, accelerometer scale factor and 24th order

error term of antenna eccentricity, error term order is optional, error

model can be configured as random constant, random walk and

first-order Markov process.

Single and dual frequency ambiguity single epoch solution

The system integrates several of the most advanced single epoch

ambiguity resolution techniques. Different from the current common

OTF method, it can solve single-frequency and dual-frequency

ambiguities efficiently and reliably in a few seconds. There are no

common initialization issues at present. For dual-frequency data, the

success rate will be higher. The single epoch solution of ambiguity can

effectively solve the observation data of short time slices, which is of

great significance for practical engineering applications, especially for

harsh environment applications.
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Direct input of multi-format data

The system can read raw data in a variety of branded receiver formats,

raw data format and RINEX format data of receivers such as Thales,

NovAtel, CMC, Trimble, Csi, NavCom and Javad, etc, and for data that

needs to be processed at one time, it can contain multiple source data,

that is, it contains observation data in different formats, which is

important for practical complex work. At the same time, in the data

processing, the system uses the direct read-in method instead of the

format conversion first, and then the two methods of reading, it is

more convenient for user.

IMU data supports incremental data and rate data input, is compatible

with Novatel IE software imr format, and can be converted to ASCII

format for easy viewing.

User assisted solution

For advanced users and complex applications, the system has many

interfaces to facilitate user-assisted solution. The system provides a

friendly star selection interface, the user can manually exclude some

badly observed satellite data; the user can also select the calculation

method such as filtering direction, filter smoothing, zero speed update,

Kalman filter dynamic updating and measuring updating time.

Friendly graphical interface

Shuttle software provides a user-friendly interface that allows users to

perform various graphics operations such as zooming in, zooming out,

roaming, and ranging. The software provides a user interactive query

function, which has a two-way query function for checking data from

attribute data and checking attribute data from a graphic. It has

information display functions such as star map, original data, and

positioning attitude measurement results, so that users can analyze

and optimize the positioning results.
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User-defined output

Users can define the content, unit and format of the output according to

their specific needs, and save it in the output configuration file for

convenient use.

Coordinate system management

The system supports common coordinate systems, supports

user-defined coordinate systems, and provides conversion between

different coordinate systems.

Favorites management

Provide base station coordinate collection and IMU error model

collection function, which is convenient for users to save the next

calculation.

Angle conversion

The system provides the mutual conversion function between the three

angular units of degrees, seconds and degrees, which is convenient for

users to convert angles in different environments.

Time conversion

The system provides conversion between GPS system time, GPS date,

GPS week seconds, and GPS days and seconds.

Data decoding

The system provides GNSS, IMU and odometer data decoding.

System main interface

Shuttle is generally divided into five parts: title bar, menu bar, toolbar,

view area and status bar.
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1. Title bar:

Shows the current system processing project path.

2. Menu bar:

The menu bar is located below the Shuttle title bar. Based on user

habits, menu items such as file (F), processing (P), configuration (C),

output (O), tool (T), and help (H) are set here. The uppercase letters

after each menu indicate the shortcut keys corresponding to the menu.

Use the “Alt key + corresponding letters” key combination to select the

corresponding menu item. New operations, add/delete files, star

selection, output, and help can all be done here.

3. Toolbar:

Title bar
Menu bar: display function menu

Toolbar: List common shortcuts

View area: display processed graphics and list information

Status bar: display the current view area scale, plane coordinates, processing epochs, and
processing status
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The toolbar is located below the menu bar. Includes new projects,

open projects, save projects, add/remove files, export wizards,

dynamic precision single points, dynamic differential positioning,

GNSS/INS combined positioning, processing, configuration, GNSS star

selection, drawing, viewing raw data, output DXF, point selection, full

image, rover full picture, zoom in, zoom out, roaming, range, capture

ranging, display grid, and help operations.

4. View area:

Located below the toolbar. It is used to display the graphics processed

by the user. The whole picture, the full picture of the rover, zoom in,

zoom out, roaming, star selection, etc. can all be completed in the

view area.

5. Status bar:

Located below the view area. Displays the current view area scale,

view area coordinates, number of processing epochs, and processing

mode information.

System operating environment

Minimum hardware configuration

■ CPU：Intel Pentium IV 1GHz or faster processor

■ Display：1024*768

■ Hard disk：40GB

■ Memory：1GB

Recommended hardware configuration

■ CPU：Intel Pentium IV 1GHz or faster processor

■ Display：1024*768

■ Hard disk：≧40GB
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■ Memory：2GB

Software configuration

Operating system versions supported by Shuttle include:

■ Windows NT

■ Windows 2000

■ Windows XP（win7、win8、win10）
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Engineering Management

 New Construction

 Add or delete data files

 Open the project

 Save the project

CHAPTER2
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New construction

Click the File > New Project menu item or Toolbar New Project button.

In the pop-up new dialog box, enter the project name. The system

saves the project file with the extension ".pro", as shown in the

following figure.

Click the Save button and the system will automatically pop up the

Input Project File dialog box for users to add GNSS raw observation

data and IMU data files.

Note: After creating a new project file, you must add the relevant data file to the project to

complete the creation of the new project. See Adding or Deleting Data Files below.

Add or delete data files

Click the File > Add/Remove File menu item or the Toolbar

Add/Remove File button, the system displays the Input Project File

dialog box, which contains six property pages: GNSS base station,

GNSS rover, GNSS positioning velocimetry results, IMU, odometer

data, total station data.

After adding all the input files, click the OK button below the input

project file dialog box to start importing data. If the input file contains
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both GNSS base station and GNSS rover data, after the import data is

completed, the single point positioning is automatically performed,

and display the track in the view area (if you use the GEOSUN .dat file ,

you can get the relevant file by stream file sorting), as shown in the

figure below.

1. GNSS base station property page

Display the complete path, coordinate information and antenna high

information of the base station information file, which is convenient

for the user to view the data information of the specified base

station information file, as shown in the following figure:
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 Add base station information file

Click the Add button in the base station property page to specify the

base station information file to be added in the pop-up open dialog

box.

The data file formats supported by the system include NovAtel OEM4

(*.gps), Thales (*.raw), South (*.sth), Rinex (*.obs), Rinex (*.**o), CMC

(*.log). ), Trimble RT17 (*.dat), Javad (*.jps) and other forms of file

format storage. The user can make a selection in the File Type

drop-down box. As shown below:
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After the base station information file is specified, the full path of the file is

displayed in the file name list box. As shown below:

 Enter base station coordinate information

In order to improve the accuracy of the solution and obtain accurate

information of the rover, it is recommended that the user select the

input latitude and longitude to the nearest nine decimal places when
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inputting the latitude and longitude information, and improve the

system solution accuracy. If the user cannot know the base station

coordinates or only care about the baseline information, you can

choose to use approximate coordinates.

If the base station's right-angled coordinates (X, Y, Z) in the current

coordinate system are known, you can enter the XYZ information in

the pop-up base station's solid coordinate dialog box by clicking the

Input Ground Solid Coordinate button. The system will convert to the

latitude, longitude and elevation information under the current

specified coordinate system and display it in the property page, as

shown below.

In order to facilitate the user to reuse the defined base station

information, the system provides a "Favorites" function. After entering

the coordinate information, click the Add to Favorites button, enter

the point name in the pop-up Reference Base Station dialog box, and

click the OK button to save the location information of the point to the

favorites. As shown below:

The next time you use it, just click the Favorites button to select the
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site information in the pop-up Reference Base Station Favorites dialog

box. As shown in the figure below, click the OK button and the base

station property page will be automatically loaded and displayed the

coordinate information of the site.

 Input antenna high information

Antenna height refers to the distance from the center of the receiver

antenna to the ground point (measurement mark center, ground

measurement point, etc.). According to different measurement

methods, the antenna height can be divided into two types: oblique

height and vertical height. The oblique height refers to the oblique

distance from the ground mark of the measuring point to the edge of

the antenna or the marking point of the measuring board; the vertical

height is the distance from the ground mark of the measuring point to

the reference point (ARP) of the antenna. The system defaults to the

vertical input. If the oblique high check button is selected, the oblique

high input is used. When using oblique high input, the antenna radius

must be entered. It is recommended that the user accurately input the

antenna high information to the millimeter level to improve the

system resolution accuracy. As shown below.
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After the input antenna high information is completed, the operation

of adding a base station information file is completed. Click the OK

button at the bottom of the Input Project File dialog to complete the

file addition.

1. GNSS rover property page

Display the complete path and antenna height information of the

rover information file as shown in the figure below. The process of

adding rover file and antenna high information is similar to base

station.
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2. GNSS positioning velocity result property page

Add GNSS positioning velocimetry results and external event files as

shown below.

If the user has obtained the GNSS positioning speed measurement

result by using the GNSS base station and the rover data, the GNSS
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positioning speed measurement result may be directly used as the

input of the GNSS/INS combination without adding the base station

and the rover information file, and if the user adds the external event

point file, the event point can be displayed in the track by a

rectangular marker point in the view area after processing. See

Appendix III for the GNSS positioning speed measurement result file

format.

3. Odometer data / total station data property page

Add external observations, including odometer data and total station

data, similar to the two property pages.

For terrestrial applications, especially in urban areas, GNSS signals are

susceptible to be obscured, odometer information can be used as an

effective external observation input to Shuttle assisted INS positioning,

and for high-speed rail ride detection, etc., total station information

can then be used together with the odometer information as a valid

external observation input to the Shuttle Assist INS.
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4. IMU property page

Display the IMU data file path and IMU data format, and add the

gimbal file as shown below. IMU data supports data formats such as

Novatel imr and navigational imu.
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Open project

Run the system, click File > Open Project menu item or Toolbar to

open the Project button, select the specified project file in the Open

Project dialog box that pops up, and then click the Open button, or

double-click the specified project file to open the specified project. As

shown below. When the project is opened, the system will

automatically revert to the last saved state.
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Tip: Shuttle software engineering is saved with a .pro extension.

Save project

The system can save the project configuration information, the

original data information and the processing result information of the

format of the GEOSUN Navigation.

1. Save project configuration information and raw data files

After the user completes the new project, the File > Save Project menu

item and Toolbar Save button will be in the active state. You can save

the current project configuration information by clicking File > Save

Project menu item or Toolbar Save button. Meanwhile, the system will

generate a binary observation data file with the same name as the

added station information file and with the extension ".epo" in the

project-related data directory.

Tip: Compared with the original file, the observation data file of GEOSUN Navigation format

is saved in the system after the system has been modified, except for the format.

2. Save processing result information

Once the user has finished processing, the File > Save Project menu

item and Toolbar Save button will be active. You can save the current

processing result by clicking File > Save Project menu item or Toolbar

Save button. At this point, the system will generate a binary result file

with the same name as the project and a ".pos" extension in the

project-related data directory.
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Configuration

 GNSS general configuration

 INS general configuration

 Kalman filter initial variance and noise

power spectrum

 Satellite selection

CHAPTER3
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The configuration menu item provides the choice of processing

parameters and processing methods for the system during the

solution process, including GNSS common settings, INS common

settings, odometer configuration, initial variance and noise power

spectrum of the Kalman filter, and user-assisted star selection

function.

Click the Configuration > Configuration menu item or the toolbar

option button. In the pop-up Shuttle configuration dialog box, you

can modify the GNSS common settings, INS common settings,

odometer configuration, Kalman filter initial variance and noise power

spectrum, as shown below. After the user modifies each configuration

parameter in the dialog box and clicks the Save as Default button, the

system default configuration parameters can be modified.

GNSS general settings

Select the GNSS Common Settings property page in the Shuttle

Configuration dialog as shown above.

 Static mode
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 General static： For static positioning, if the user is using a

single-frequency or low-end receiver, it is recommended that

the user select normal static. The working time for users to

collect data is about 30 minutes.

 Fast static ： For static positioning, if the user is using a

dual-frequency or high-end receiver, it is recommended that the

user select fast static. The working time for users to collect data

is about 10 minutes.

 Long baseline static： If the baseline length is greater than

500km, it is recommended that the user select long baseline

static. The working time for users to collect data is about 1 hour.

Long baseline static positioning requires high quality of

observed data.

 Dynamic mode

 General dynamics： For dynamic positioning, if the user is

using a high-end receiver, it is recommended that the user

select normal dynamics. The general dynamic is mainly for the

dual-frequency data of medium and short baselines within 50

km and the single-frequency data within hundreds of kilometers.

The DOFCOM method is used to solve the full-circumference

ambiguity of the carrier phase with an accuracy of centimeter.

 Low precision dynamic： For dynamic positioning, if the

user is using a low-end receiver, it is recommended that the user

select low-precision dynamics. Low-precision dynamic

positioning uses dynamic Kalman filtering and does not use

carrier phase observation. Low-precision dynamic accuracy is

low, but high reliability, suitable for applications that require less

precision but require high number of points.

 Long baseline dynamics： For dynamic positioning, if the

baseline length is greater than 50km, it is recommended that

the user select long baseline dynamics. Long baselines must use
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dual-frequency data and precision ephemeris data to support

GPS/BDS multimode data.

 Minimum number of epochs in the segment

 Minimum number of epochs in the segment： The number

of epochs in units of seconds

 Other settings

 Satellite elevation angle： Set the minimum altitude angle in

degrees, the system selects the satellite according to the set

mask angle, and the satellite below the minimum altitude angle

will be rejected by the system during the solution process;

 Height angle weight： The quality of the satellite height

angle is different for different observations. During the solution

process, the satellite status of the same satellite at different

times may vary greatly. Users can choose equal rights or

according to the height angle according to the environment.

 Receiver clock compensation： Optional compensation or

no compensation

 External event time offset： External event point time offset,

manual input

 Linear constraints： Trajectory constraints of high-precision

road sections such as railways

 Display limit： If the choices under four different precisions

do not match, they are displayed.

 Whether to save the intermediate result file： Choose to

save or not save.

INS general settings

In the Shuttle configuration dialog, select the INS Common Settings

property page as shown below:
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 IMU mounting axial

Defines the mounting orientation of the IMU sensor coordinate

system (s-frame) in the carrier coordinate system (b-frame).

The three axes of the carrier coordinate system are respectively

defined as rightward, forward, and natural directions. The user

needs to configure the axial direction of the carrier coordinate

system corresponding to the X, Y and Z axes of the IMU according

to the actual installation.

 IMU to navigation center position vector

Defines the eccentricity vector of the IMU Center and the Carrier

Navigation Center in meters.

 GNSS to navigation center position vector
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Define the eccentricity vector of the GNSS antenna and the carrier

navigation center in meters. If the IMU center is used as the

navigation center, this parameter is the eccentric vector of the

GNSS antenna to the IMU center.

 Odometer to navigation center position vector

Define the eccentric component of the odometer and carrier

navigation center in meters. If the IMU center is used as the

navigation center, this parameter is the eccentricity vector of the

odometer to the IMU center.

 Total station to navigation center position vector

Define the eccentric component of the total station and carrier

navigation center in meters. If the IMU center is used as the

navigation center, this parameter is the eccentricity vector of the

odometer to the IMU center.

 INS configuration

 Coarse alignment time: The length of the static data used as

the coarse alignment, in seconds.

 Wheel Sensor configuration

 Odometer scale factor: Default 1, depending on the situation.

 WS installation error pitch angle: Known WS installation error

pitch angle, if unknown, set zero.

 WS installation error roll angle: Known WS installation error

roll angle, this value must be determined by other means.

 WS installation error heading angle: WS installation error

heading angle is known. If unknown, set zero.

 WS right eccentric component convergence RMS: WS right

eccentric component convergence RMS threshold during

filtering.

 WS forward eccentric component convergence RMS: WS

forward eccentric component convergence RMS threshold

during filtering.
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 WS eccentric component convergence RMS: WS upper

eccentric component convergence RMS threshold.

 WS scale factor convergence RMS: The WS scale factor

converges on the RMS threshold when filtering.

 WS mounting error pitch angle convergence RMS: WS

Mounting Error Pitch Angle Convergence RMS Threshold.

 WS installation error heading angle convergence RMS: WS

installation error heading angle convergence RMS threshold.

 WS filter start position RMS: The position RMS threshold of

the system when the WS filter starts.

 WS filter start minimum speed: The speed threshold of the

system when the WS filter starts.

 Filter configuration

 Filter smoothing: Unsmoothing performs only one pass of

filtering in chronological order; smoothing performs three-pass

filtering in round-trip order and inputs the optimal result. Users

are advised to use smooth processing methods, especially if the

GNSS observation conditions are poor.

 Filter bridge: Whether to use filter bridge.

 Doppler velocity measurement: Whether to use the Doppler

velocity measurement as an external observation of the Kalman

filter.

 Perform zero speed update: Whether to use zero speed

update (ZUPT).

 Speed threshold: The speed threshold at which the zero

speed update is performed. Below this threshold, the carrier is

considered to be at a standstill.

 System dynamic update interval: The Kalman filter status

update interval can be selected from 0.1s, 1s, 2s, 5s and 10s.

 Measurement update interval: The Kalman filter

measurement update interval can be selected to be

synchronized with the GNSS sampling interval, 1s, 2s, 5s, and
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10s.

 Navigation result save interval: It can be selected to

synchronize with the original IMU data sampling interval, 0.005s

(200Hz), 0.01s (100Hz), 0.05s (20Hz) and 0.1s (10Hz). The save

interval determines the time interval between the final output.

 Use environment: Select the appropriate environment

according to the user's specific usage scenario.

Kalman filter initial variance and noise power spectrum

Select the Kalman filter initial variance and noise power spectrum

property page in the Shuttle configuration dialog as shown below:

Shuttle's Kalman filter error state model has a total of 24 orders, which

can be simulated as random walk or random constant. The power

spectral density parameter is set to zero to be a random constant. The

user must configure the initial standard deviation and power spectral

density of the following error terms according to the type of IMU used.

At the same time, in order to improve the friendliness, click on the

collection from the favorites, and select the common AGS300
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configuration item from it, or select the corresponding configuration

item according to requirements.

Kalman filter initial variance and noise power spectrum

 Initial standard deviation of position (m)

 Position power spectral density (m/s^(1/2))

 Speed initial standard deviation (m/s)

 Speed power spectral density (m/s/h^(1/2))

 Initial standard deviation of attitude angle (deg)

 Attitude angle power spectral density (deg/h^(1/2))

 Gyro bias initial standard deviation (deg/h)

 Gyro bias power spectrum (deg/h^(3/2))

 Accelerometer bias initial standard deviatio (mg)

 Accelerometer bias power spectral density (mg/h^(1/2))

 Gyro scale factor initial standard deviation ( )

 Gyro scale factor power spectral density ( /s^(1/2))

 Accelerometer scale factor initial standard deviation ( )

 Accelerometer scale factor power spectral density ( /s^(1/2))

 GNSS antenna position eccentricity initial standard deviation (m)

 GNSS antenna position eccentric power spectral density (m/s^(1/2))

Shuttle provides a "favorites" feature for IMU error model parameters.

After configuring the error model parameters, click the Save to

Favorites button, enter the configuration name in the Save to IMU

Favorites dialog box that pops up, and click the OK button to save the

error model parameters of the IMU to the favorites. As shown below:
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The next time you use it, just click the Get From Favorites button to

select the error configuration model in the pop-up IMU Favorites

dialog box, as shown below, click the OK button, the error model

parameters of the IMU are automatically loaded and displayed in the

initial variance and noise power spectrum property pages of the

Kalman filter.

Satellite selection

During the solution process, the distribution of the same satellite may

vary greatly in different time periods. Shuttle provides a satellite

selection function that enable users to select satellites that are

participating in the solution, and set the satellites in the period of poor

distribution and observation to be disabled, can greatly improve the

accuracy of the system solution, and achieve the role of auxiliary

solution.

Click the Configuration > GNSS Stars menu item or the toolbar star

selection button or the star selection tab below the current view. The

current view will switch to the star selection interface, as shown in the

following figure:
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The upper part of the view consists of five parts: the system

information start system time, the end system time, the time scale, the

time scale of the leftmost position of the current view, and the time

scale time of the current cursor of the mouse. As shown below:

In the above figure, “4:39:30.000 on December 14, 2006” indicates

the system time at which the station information file starts;

“5:22:40.000 on December 14, 2006” indicates that the station

information file ends the system time; The blue "4:39:30.000 on

December 14, 2006" indicates the time scale of the leftmost position

of the current view; the pink "4:41:42.000 on December 14, 2006"

indicates the time scale time of the current mouse cursor; below is the

time scale.

The part of the star selection view consists of two parts: the satellite

number of the station information file and the observation status over

the entire time period, as shown in the following figure:
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In the above figure, the top line is the file path of the station; the left

side of the station shows the observed satellite PRN number; the right

side shows the usage of the corresponding satellite in each period, the

green part indicates good observation, and the gray part indicates

Not used during the solution process. Right-click in the satellite PRN

number edit box, and the system will pop up the prohibition period

and allow time menu items to disable or enable the satellite to

participate in the solution. As shown below:
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You can also click the left mouse button in the right display bar to

select the satellite usage at a certain moment, then click the right

mouse button, the system will pop up the prohibition period, allow

time menu items. As shown below:

The user can also draw a frame for a specified time period of a single

or multiple satellites in the display bar, and then click the right mouse
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button in the selected area to select the forbidden time period and

allow time period menu items to perform the state setting operation.

As shown below:

In the star selection view, the observation state of the base station and

the rover can be compared, and the synchronization is performed and

the time period in which the observation is in good condition is solved.

After the status setting of the specified satellite or the specified

satellite time period is completed, the system will save the star

selection operation information when the star selection dialog box is

closed.
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Positioning and attitude

measurement solution

 GNSS dynamic precision single point

positioning

 GNSS dynamic differential positioning

 GNSS/INS combined positioning and attitude

measurement

CHAPTER4
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Shuttle is a high-precision GNSS/INS combined positioning attitude

measurement system, and also provides GNSS post-processing

solution, including GNSS dynamic precision single point positioning

and GNSS dynamic differential positioning.

The GNSS/INS combined positioning attitude uses a high-order

Kalman filter to establish a random error model of up to 24 orders for

the system, and performs algorithms such as round-trip filtering,

smoothing, and zero-speed updating. Shuttle supports high-precision

odometer input and assists INS solution with Kalman filter to provide

continuous and reliable position information even under harsh GNSS

observations.

Shuttle's GNSS positioning solution is based on the excellent fuzzy

degree core algorithm, which combines several of the most advanced

single epoch ambiguity solving techniques. It is different from the

current common OTF method, can be highly efficient and reliable in a

few seconds solve the single-frequency and dual-frequency ambiguity,

so there is no initialization problem of the current software, especially

for the harsh environment application and short-time data.

GGPoS supports multi-sampling rate solution, this means when the

original data sampling rate of the base station information file and the

rover information file are inconsistent, the system can also add these

files to the project for correct solution, without the need to perform

internal or thinning operations when adding files, the system will

automatically interpolate or thin the base station raw data to realize

the difference decomposition calculation, which is convenient for

practical work.

Precision single point positioning

The observation data of a dual-frequency GNSS receiver and the
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corresponding precision ephemeris and precision clock are used to

complete. The system data structure is based on the dual-frequency

C/A code, P code, carrier phase and Doppler shift observation value to

achieve precise single point positioning.

To perform dynamic precise single point positioning, after adding the

rover dynamic observation information file and the precise ephemeris

file, click the Process > GNSS Dynamic Precision Single Point

Positioning menu item or the dynamic precision single point

positioning button on the toolbar. The system will enter Dynamic

precision single point positioning process.

GNSS dynamic differential positioning

In the case of positioning observation, if the receiver moves relative to

the surface of the earth, it is called dynamic differential positioning.

After adding the base station information file and the rover

information file, click the Process > GNSS Dynamic Differential

Positioning menu item and the Toolbar Dynamic Differential

Positioning button. If the current project has not been solved, the

system will directly solve the solution; if the current project has been

subjected to the positioning solution operation, the system will

re-calculate. During the solution process, the processing progress and

the number of epochs that have been solved will be displayed in real

time on the system status bar. After the solution is completed, the

system will display the solution result of dynamic differential

positioning in the view area, and display the number of solving epochs

and the solution method in the lower right corner of the status bar. As

shown below:
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GNSS/INS combined positioning and attitude measurement

Before the combined positioning and attitude measurement, you

must add the GNSS base station file, GNSS rover file and IMU file, and

then click the Process > GNSS/INS combined positioning attitude

menu item or the toolbar GNSS/INS combination button to solve the

combined data in one step; The combined positioning and attitude

measurement can also be solved step by step. First, the GNSS/INS

dynamic differential positioning is performed. The operation is

consistent with the previous section, and then the GNSS/INS

combined positioning and attitude measurement is performed.

If the user has used GNSS dynamic differential positioning to output

GNSS positioning speed measurement results, only the dynamic

difference result file and the IMU file are added. At this time, the

GNSS/INS dynamic differential positioning is disabled, and only the

GNSS/INS combined positioning attitude measurement can be

performed.

Combined positioning and attitude measurement can also solve

high-precision odometer data and total station data. If the user adds
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GNSS data, IMU data and odometer data, and then performs

GNSS/INS combined positioning and attitude measurement, the

system will use the odometer data to correct the INS error if the GNSS

is interrupted for a long time.
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Output

 Output

CHAPTER5
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Output

Shuttle provides data output in multiple formats, and users can

customize the output format according to their specific needs. The

result data is output in .TXT text file format, which is convenient for

users to perform post-processing. User-defined output parameters

and unit information will be saved to the output configuration file for

next output.

After the system completes the specified solution operation, the

Output > Output Wizard menu item and the toolbar output wizard

button will be in the active state.

1. Click the Output > Output Wizard menu item or the toolbar output

wizard button. The output wizard dialog box will pop up as shown below.

The output file name edit box displays the full path of the output

result file.
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Tip: The system default output file path is the same as the current project directory. The

default output result file name is "<project name>.txt".

The user can click the Browse button to customize the output file path

and output file name in the pop-up open dialog. As shown below:

After defining the output file save path and file name, the system

returns to the Output Wizard dialog box and displays the full path of

the output result file in the Output File Name edit box.

The template list box of the Output Wizard dialog box displays a list of

all the templates saved by the system. Each template contains

predefined output parameter names and parameter unit information.

All template information will be saved in the system configuration file.

Users can create new templates, view specified template information,

and delete specified templates according to specific needs.

2. Create a new output template. Click the New button of the Output

Wizard dialog box, and the Create New Template dialog box will pop up. As

shown below:
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In the Create New Template dialog box that pops up, type the output

template name, click the OK button, the system returns to the Output

Wizard dialog box, and the newly created output template name is

displayed in the template list box. As shown below:

Note: At this time, the system has created a new output template with the specified name,

but the template does not contain any output parameter information. If the output wizard

dialog box is closed, the newly created template will be invalid and the system will not save it.

Edit the output parameters and parameter unit information. Select the newly

created output template, click the Output Wizard dialog property button, the

system pops up the custom output dialog box for the user to customize the

output parameters and output parameter unit selection. The user can also

directly click the specified template name in the template list box of the

Output Wizard dialog box to enter the custom output dialog box. As shown
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below:

The source variable label box on the left side of the custom output

dialog box includes the parameter information that the system

supports for output. You can select the drop-down box to view the

source variable information, including

time/date, geographic coordinates, projected coordinates , speed/offset,

and attitude angle, baseline information, standard deviation and

statistics. As shown below:

Select any item in the drop-down box, the system displays the item

information in the drop-down list box to include all parameter

variables. As shown below:
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Double-click the specified parameter in the list box or click the Add button

under the list box to set the unit and output length of the parameter in the

output format dialog box that pops up. As shown below:

Select the specified unit and set the total length and decimal place of

the output parameter data, click the OK button, the system will return

to the custom output dialog box, and display the output parameter

name and the output unit name of the parameter in the output

variable list box on the right side of the dialog box. As shown below:
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 Click the Delete button to remove the selected variable from the

output Variables list box

 Click the format button to view the unit of the variable selected in the

output variable list box and the total length and decimal place

information of the output parameter data in the pop-up format

output dialog box, which is convenient for the user to view and

modify again;

 Click the Move Up button to swap the selected variable in the output

variable list box with the previous variable and move it up by one;

 Click the Move Down button to swap the selected variable in the

Output Variables list box with the next variable and move it down by

one.

Click the Custom Output Dialog OK button to complete the variable

editing operation for the specified output template. The system saves

the edited output variable information to the template and returns to

the Output Wizard dialog box. As shown below:
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。

Tip: If the user needs to re-edit the output parameters and parameter unit

information, repeat step 3.

3. Set the output coordinate system, output mode, and output limits.

The Settings button in the Output Wizard dialog box is used to set the

coordinate system and output parameter mode to which the output

parameters are referenced. It is convenient for users to view data information

and data quality from different angles. Click the Settings button, the system

pops up the parameter settings dialog box, as shown below:
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The coordinate system name drop-down box at the top of the dialog

box lists all the coordinate systems owned by the current system,

including the coordinate system added by the user. The system

defaults to the WGS84 coordinate system.

The output mode at the bottom of the dialog box can select the

output standard of the output parameters, including each epoch

output, full-second output, and output event. The system defaults to

output per epoch. The output limit can be selected for output

accuracy, including all outputs, less than 0.05 meters, less than 0.10

meters, less than 0.15 meters, and less than 0.20 meters. The system

defaults to all outputs.

After selecting the output coordinate system, output mode and

output precision, click the OK button, the system will return to the

output wizard dialog box to complete the parameter setting operation

of the output file. At the same time, the system saves the settings as

the system default settings. When the user performs the output

operation again, the system will output according to the previous
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parameter settings, without having to repeat the output setting

operation each time.

5. Output the file. Select the desired output template, click the output

button in the Output Wizard dialog box, the system will output the result

file according to the specified output file path and the specified file name,

and a dialog box will pop up to display the output file. As shown below:

Tip: The system comes with two output templates, which are positioning speed measurement

output and positioning attitude measurement output, respectively corresponding to GNSS

dynamic difference and GNSS/INS combined positioning and attitude measurement

processing data output, the specific format to participate in Appendix III.
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Graphical operation

 Select point

 Full picture

 Zoom in

 Zoom out

 Roaming

 Distance measurement

 Capture ranging

CHAPTER6
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Shuttle provides a user-friendly interface that allows users to perform

various graphics operations such as zooming in, zooming out,

roaming, and ranging. The software provides a user interactive query

function, which can perform two-way query from the attribute data

check graph and from the graph check attribute data.

Point selection

After the software completes the solution, the processing result will be

displayed in the view area of the main interface of the system. Each

cross in the view area represents the positioning attitude information

of an IMU epoch, and the circle represents the epoch information of

the GNSS/INS combination. The other box indicates the event point (if

you add an external event file). Click the toolbar selection button and

click any point in the view area. The system selects the point with a

yellow cross and pops up the rover information dialog. As shown

below:

The serial number, time, and seconds information can be modified

according to actual needs, and will jump to the corresponding point to

obtain related information. During operation, after entering the value,

you need to press Enter to confirm.The Rover Information dialog
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displays basic information, base station raw data, rover raw data, star

map, position, velocity, baseline, etc.

Basic Information

The basic information of the rover includes: the serial number of the

selected point, date, time, GPS week, GPS week second, mode, quality,

pass Ratio value and PDOP. As shown below:

Serial number: The serial number starts from zero. Click the button

to display the information of the next sequence point; click the button

to display the information of the previous sequence point.

Tip: If user need to view the point information of the specified serial number, you can directly

enter the specified number value in the serial number, time, and week second edit boxes, and

then press the Enter key to quickly view the specified number point information. The point

corresponding to the number will also be directly selected in the view area.

 Date format: y/m/d

 Time format: hour/minute/second

 Week: GPS week

 Second: GPS week second

 Mode: Static positioning, dynamic forward positioning, dynamic
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reverse positioning and dynamic combined positioning

 Quality: 0（0 m<positioning solution result <=0.05 m）；

1（0.05 m< positioning solution result <=0.10 m）；

2（0.10 m< positioning solution result <=0.15 m）；

3（0.15 m< positioning solution result <=0.2 m）；

4（0.2 m< positioning solution result）；

 Passing the Ratio value: The Ratio value is the ratio of the square of

the error in the sub-minimum unit of the solution to the square of the

error in the minimum unit weight when the search algorithm is used

to determine the ambiguity parameter of the whole week. If the ratio

exceeds a certain value, the Ratio value is passed, otherwise it is not.

1 means pass; 0 means not pass.

 PDOP：Position Dilution of Precision The accuracy factor calculates

the geometric accuracy factor based on the satellite's distribution, so

that the accuracy level of GNSS positioning can be roughly evaluated.

Position information

The rover location information includes longitude, latitude, east, north,

and sky coordinates of the local coordinate system, and X, Y, and Z of the

ground system, and the standard deviation of the east, north, and sky

coordinates of the local coordinate system. As shown below:

 The standard deviation information of the east, north, and height
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coordinates of the local coordinate system and the east, north, and

sky coordinates of the local coordinate system are displayed in

international standard units.

 By default, longitude and latitude information, the system displays in

degrees. Users can click the degree and minute check box d.mmsssss

in the property page, the system will display in degrees, minutes and

seconds. As shown below:

Velocity information

The speed information includes the eastward speed, the northward

speed, the upward speed, and the standard deviation of the speed in

the three directions of the local coordinate system, all displayed in

international units (meters/second). As shown below:
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Attitude information

The attitude information includes the pitch angle, roll angle, and

heading angle of the carrier in degrees (deg), as shown in the

following figure. The attitude information is displayed only after the

GNSS/INS combination processing.

Tip: The carrier attitude angle is also called the Euler angle. Its definition is related to the

definition of the coordinate system and the rotation order, but the rotation matrix is always

the same regardless of the definition. Shuttle defines the XYZ axes of the carrier coordinate

system as the right, forward and upward directions of the carrier respectively. The navigation

coordinate system XYZ axes are defined as east, north and sky, respectively. The carrier

attitude angle is defined as being rotated by the navigation coordinate system in the order of

Z, X, Y to the navigation coordinate system, and the three rotation angles are the heading

angle, the pitch angle and the roll angle, respectively, where "X" and "Y" are the X axis after

one rotation of the navigation coordinate system and the Y after the second rotation

respectively.

Baseline information

The baseline information includes (X, Y, Z) vector information of the

point on the geocentric coordinate system, (east, north, up) vector

information on the local coordinate system and the baseline length of

the point to the base station, in meters. The height angle and azimuth

angle formed by the point and the base station are in degrees. As

shown below:
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Rover raw data

Satellite number (PRN) including satellite observation data, GPS type

(GPS/GLONASS/BD), C/A code (C1), P code (P1 and P2), carrier phase

(L1 and L2), Doppler value (D1 and D2) and signal-to-noise ratio (S1

and S2) information, the specific display content is displayed

according to the observation information of the original data file. As

shown below:

Different colors are used in the list to distinguish the usage of the data.

Black indicates that the data is in use, if the altitude angle is too low,

or the specified satellite observation data is set to disabled when the

star is selected, the specified line in the list box will be displayed in

red.
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Base station raw data

Satellite number (PRN), satellite type (GPS/GLONASS/BD), C/A code

(C1), P code (P1 and P2), carrier phase (L1 and L2), Doppler value (D1)

of base station observation data And D2) and signal-to-noise ratio (S1

and S2) information, the specific display content is displayed

according to the observation information of the original data file. As

shown below:

IMU raw data

The IMU raw data gives the angular rate and scale information

collected by the gyro and accelerometer, where the angular rate is in

radians and the ratio is in m/s2. As shown below.

Satellite map

This property page displays the status of the observation satellite at

that point in both a starry sky map and a list. The starry sky map is
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shown below:

The current observed satellite distribution is shown in the starry sky

map, and the satellite is represented by a circle.

A green circle indicates that the specified satellite is in use;

A gray circle indicates that the specified satellite is disabled;

A red circle indicates that the specified satellite has a signal-to-noise

ratio below 20;

The dark blue circle color indicates that the satellite is not co-viewed,

that is, the rover station observes the satellite but the base station

does not observe it.

The contents of the satellite map list box include: PRN (observation

satellite number), satellite altitude angle, satellite azimuth and satellite

signal to noise ratio information. As shown below:
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Tip: If the user wants to view other information, can click any point directly in the view area

while the toolbar standard button is selected, without closing the Rover Information

dialog box. At this time, the Rover Information dialog box will update and display the rover

information content of the currently selected point in real time, which is convenient for the

user to query in real time.

Full map

After the system performs the solution processing according to the

user-specified method, by default, the system displays the full map of

the positioning solution result in the view area. After the user

performs operations such as zooming in, zooming out, and roaming,

click the toolbar Full Button to display the base station and rover

graphics in the view area. Click the toolbar Full Button to display

the rover graphics in the view area.

Zooming in

Click the Tools > Zoom In menu item or the toolbar Zoom In button

to zoom in in the view area.

Zooming out

Click the Tools > Zoom Out menu item or the toolbar zoom out

button to complete the zoom out operation by clicking the left

mouse button in the view area.

Tip: If the operating system supports the middle axis of the mouse, scrolling the middle axis

of the mouse can also perform center zooming in and zooming out operations.
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Roaming

Click Tools > Roaming Menu Item or Toolbar Roaming button , click

the left mouse button in the view area, drag the graphic to the

specified position, release the left mouse button to complete a

roaming operation.

Ranging

Click the toolbar Ranging button , click the left mouse button in the

specified starting position in the view area, then move the mouse to

the end position and double-click the left mouse button, the system

will pop up a dialog box to display the distance from the starting

position to the ending position. As shown below:

Shooting distance

Click the toolbar Ranging button , click the left mouse button in the

specified starting position in the view area, the software will

automatically capture the epoch data closest to the click position as

the starting point, then move the mouse to the ending position and

click the right mouse button, the software will automatically capture

the epoch data closest to the click location as the end point, and a

pop-up dialog box will display the baseline information from the start
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position to the end position. As shown below:
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Tool

 Coordinate transformation

 Time conversion

 Angle conversion

 GNSS data decoding

 IMU data format conversion

 Odometer data format conversion

CHAPTER7
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Coordinate transformation

Shuttle provides the mutual conversion between geodetic coordinates

and space rectangular coordinates in different coordinate systems.

Click the Tools > Coordinate System Management menu item and the

system will pop up the Coordinate System Conversion Tool dialog box

as shown:

Click the tool in the coordinate system conversion tool to display

angle conversion, distance conversion, geodetic coordinate

conversion, grid file format conversion and ellipsoid management,

select geodetic coordinate conversion, input the coordinate value to

be converted, click the XYZ BLH button to convert space

rectangular coordinates to geodetic coordinates, click the XYZ

BLH button to convert the geodetic coordinates to spatial
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rectangular coordinates, as shown in the following figure (other

conversion methods are similar):

Time conversion

The system provides a mutual conversion between GPS system time,

GPS date, GPS week seconds and GPS days and seconds.

Click the Tools > Time Conversion menu item and the system will pop

up the Time Conversion dialog as shown below:
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 GPS system time

After entering the year, month, day, hour, minute and second

information in the GPS system time label box, click the System Time

Setting button, the system will convert the GPS date, GPS week

seconds and GPS day and second information according to the input

time information and it will be displayed in the corresponding edit

box.

 GPS date

After entering the year, month, day and second information in the

GPS date label box, click the Set Date Seconds button, the system will

convert the GPS system time, GPS week seconds and GPS days and

seconds information according to the input time information, and

display in the corresponding edit box.

 GPS week seconds

After entering the week and week seconds information in the GPS

Weekly Label box, click the Set Weeks button. The system will convert

the GPS system time, GPS date and GPS days and seconds

information according to the entered time information and display it

in the corresponding edit box.

 GPS day second

After entering the day and second information in the GPS day and

second label box, click the Set Day Second button, the system will

convert the GPS system time, GPS date and GPS week seconds
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information according to the input time information, and display it in

the corresponding edit box. .

 GPS day second and week seconds conversion

In the Days drop-down box of the GPS Day Second and Week Second

information tabs box, select the specified day of the week, after

entering the second information, click the Day Second button, the

system will convert the selected days and the entered seconds into

weeks and seconds in the edit box.

Select the specified day of the week in the drop-down box, enter the

week seconds information, click the Week Second button, the system

will convert the selected week and the entered weekly seconds

information into days and seconds in its edit box.

Tip: Press the Esc key to close the dialog and reopen it to clear all edit boxes. The user can

type in new time information for the next conversion.

Angle conversion

Shuttle provides the conversion function between the three angular

units of degrees, seconds and degrees, which is convenient for users

to convert between angles in different environments.

Click the Tools > Angle Conversion menu item and the system will pop

up the Angle Conversion dialog box as shown below:

 Enter the data in the Degrees Minutes Seconds edit box, click the
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right Degrees Minutes Seconds Conversion button , the

system will convert to the degree and radians according to the input

data, and display the conversion result in the Degree edit box and the

Radians edit box.

 Enter the data in the Degree edit box and click the right Degree

Conversion button , the system will convert the input

data into degrees, minutes, seconds and radians, and display the

conversion results in the Degrees Minutes Seconds edit box and the

Radians edit box.

 Enter the data in the Radian edit box, click the right Arc Conversion

button , the system will convert to the degree minute

second and degree according to the input data, and display the

conversion result in the Degree Minute Second edit box and Degree

edit box.

GNSS data decoding

Shuttle GNSS decoding tool can convert the original observation data

of the receiver into RINEX data format, and support the original data

format of receivers at home and abroad, such as Geosun navigation,

Trimble, Novatel, Javad, etc.

Click the Tools > GNSS Data Decoding menu item and the Geosun

Converter Tool dialog box will pop up, as shown below:
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Click the Add File button and select the original data file path in the

pop-up dialog box, the output RINEX file has the same name as the

original data by default and is saved in the same path. Users can also

click the Browse button to select a different file path. The Output

Option checkbox selects the satellite constellation that needs to be

output, output is selected, otherwise it is not output. Click the Convert

button to convert the raw data to a RINEX file, and the progress of the

conversion will be displayed in the progress bar at the bottom of the

dialog.

The user can set the RINEX header information by clicking and set the

RINEX version, receiver type, antenna type, data acquisition time,

antenna approximate position and eccentricity in the pop-up RINEX

Settings dialog box, as shown in the following figure:
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IMU data format conversion

Most IMU raw data is binary data, and Shuttle provides a tool to convert

binary data to ASCII data format for users to view raw data.

Click Tools > IMU Binary to ASCII menu item, the system pops up the

IMU data conversion dialog box, as shown below. After selecting the

IMU raw data file path, IMU ASCII data file path, and IMU type, click the

OK button to perform data conversion.
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Tip: The IMU ASCII file has seven columns, which are GPS week seconds, three-axis gyro

output, and three-axis accelerometer output, the gyro data unit is radians and the

accelerometer data unit is m/s2.

Odometer data format conversion

The method IMU data format conversion is similar.
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Appendix I：Quick start

 How to perform GNSS dynamic differential

positioning

 How to perform GNSS/INS combined

positioning and attitude measurement

This section will give you an overview of the use of Shuttle. For users who are

using Shuttle for the first time, we recommend that you first read the quick

start of this chapter.

APPEND IX1
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How to perform dynamic differential positioning

Step 1: New construction

Click File > New Project menu item or Toolbar New Project button

to enter the project name in the Create New Project dialog box that

pops up. As shown below:

Click the Save button to add the base station information file, rover

information, and antenna height information in the pop-up input

Project File dialog box. As shown below:
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Click the OK button, the system will import the data, and do the GNSS

single point positioning calculation. After the calculation, the single

point positioning result will be displayed in the view area, as shown in

the figure below, the new construction operation is completed.

Tip: The single-point positioning result is displayed as a white plus sign, and the selection

operation cannot be performed, only for user reference.

Step 2: Process the configuration (optional operation)
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The Configuration menu item provides operations for the system to

process configuration parameters and user-assisted solution function

star selection during the positioning solution process. The settings of

the processing configuration parameters can be selected according to

different practical applications to achieve different application effects.

The automatic star selection function of the system allows the user to

manually exclude some poorly observed satellite data through a

friendly interface, which is of great significance for improving the

positioning accuracy.

Click the Configuration > Process Configuration menu item or

Toolbar to process the configuration button . The GNSS Common

Settings can be modified in the pop-up Shuttle configuration dialog,

as shown below:

Tip: It is recommended that novice users use the system default GNSS settings.

Step 3: Select the star (optional operation)
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During the solution process, the satellite status of the same satellite

may be very different at different time periods. The system provides

this function so that the user can customize the satellites participating

in the solution, and set the satellites which are in the bad satellite time

period to be unavailable. It can greatly improve the accuracy of the

system solution and achieve the auxiliary solution.

Click the Configuration > GNSS Star Selection menu item or the

toolbar star selection button , the system view area will switch to the

star selection view, as shown below:

After the status setting of the specified file satellite or the specified

satellite time period is completed, the system will save the star

selection operation information when the Star Selection dialog box is

closed, as shown in the following figure:
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Step 4: Dynamic differential positioning solution

After adding the base station information file and the rover

information file, click Process > GNSS Dynamic Difference menu

item or Dynamic Differential Positioning button to perform

dynamic differential positioning solution.

After the dynamic difference is completed, the system will display the

solution result of dynamic differential positioning in the view area, and

display the solution mode, direction and number of solution epochs in

the lower right corner of the status bar. As shown below:



Project Management

79

Step 5: Select a point (optional operation)

The software provides a user interactive query function, which can

perform two-way query from attribute data check graph and from

graph check attribute. The system has an epoch-based star map

display function to solve the DOP value of the satellite observation in

real time, so that the user can analyze and optimize the positioning

result.

Click the toolbar Selection button and click any point in the view

area, the system selects the point with a yellow cross and pops up the

rover information dialog. As shown below:
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The Rover Information dialog displays basic information, rover raw

data, base station raw data, star map, location, speed, and baseline,

etc.

Step 6: Output

After the system completes the positioning solution operation, click

the Output > Output Wizard menu item or the toolbar Output

Wizard button , the Output Wizard dialog box will pop up, as

shown in the following figure:

Select the output template name, or create a new output template,

click the Properties button, and select the output item in the Custom

Output dialog box, as shown below:
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Click the Settings button to set the coordinate system, output mode,

and output precision in the Parameter Settings dialog box, as shown

in the following figure:

Click the OK button and the system will return to the Output Wizard

dialog box to complete the parameter setting operation of the output

file.

Click the Output button in the Output Wizard dialog box, the system

will output the result file according to the specified output file path

and the specified template, and a pop-up dialog box will display the
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output file. As shown below:

Refer to the Output chapter for the creation and modification of

output templates.

How to perform GNSS/INS combined positioning and attitude

measurement

Step 1: New construction

Click File > New Project menu item or Toolbar New Project button to

enter the project name in the Create New Project dialog box that pops up. As

shown below:
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Click the Save button to add the positioning speed measurement

result (dynamic difference result), IMU file and IMU type in the pop-up

Input Project File dialog box. As shown below:
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Click the OK button, the system will import the data, and do the

calculation. After the calculation is finished, the result will be displayed

in the view area, as shown in the following figure, the new

construction operation is completed.

Step 2: Process the configuration (optional operation)

The Configuration menu item provides operations for the system to

process configuration parameters and user-assisted solution function

star selection during the positioning solution process. The settings of

the processing configuration parameters can be selected according to

different practical applications to achieve different application effects.

Click the Configuration > Process Configuration menu item or

Toolbar to process the configuration button , in the pop-up Shuttle

configuration dialog box, you can modify the GNSS common settings,

INS common settings, and the initial variance and noise power

spectrum of the Kalman filter, as shown in the following figure. . Refer



Project Management

85

to the configuration chapter for parameter descriptions.

Tip: It is recommended that novice users use the system default GNSS settings, the INS

settings and Kalman filter settings must be set according to the actual installation and IMU

model.

Step 3: GNSS/INS combined positioning and attitude calculation

Click the Process > GNSS/INS Combined Positioning and Attitude

Measurement menu item or the GNSS/INS Combined Positioning

and Attitude Measurement button to perform a combined

positioning and attitude calculation.

After the solution is completed, the system will display the solution

result of the GNSS/INS combination positioning in the view area. As

shown below:
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Step 5: Select a point (optional operation)

The software provides a user interactive query function, which can

perform two-way query from attribute data check graph and from

graph check attribute. The system has an epoch-based star map

display function to solve the DOP value of the satellite observation in

real time, so that the user can analyze and optimize the positioning

result.

Click the toolbar Selection button and click any point in the view

area, the system selects the point with a yellow cross and pops up the

rover information dialog. As shown below:
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The Rover Information dialog displays information such as location,

speed, and baseline, etc.

Step 8: Output

After the system completes the positioning solution operation, click

the Output > Output Wizard menu item or the toolbar Output

Wizard button , the output wizard dialog box will pop up, as

shown in the following figure:

Select the output template name, or create a new output template,

click the Properties button, and select the output item in the Custom

Output dialog box, as shown below:
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Click the Settings button to set the coordinate system, output mode,

and output precision in the parameter settings dialog box, as shown in

the following figure:

Click the OK button and the system will return to the Output Wizard

dialog box to complete the parameter setting operation of the output

file.

Click the Output button in the Output Wizard dialog box, the system

will output the result file according to the specified output file path

and the specified template, and a pop-up dialog box will display the

output file. As shown below:

Refer to the Output chapter for the creation and modification of

output templates.
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Appendix II: Shuttle File List

 Shuttle generate file list

APPEND IX2
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Shuttle generate file list

After the Shuttle is running and the solution is completed, the following

related files will be generated, as follows:

 Project configurations file "<project name>.pro". The system saves

the file to the directory defined by the user creation project. An

example of the data format is as follows:
##POSMODE## // Solution mode
24
##BASENUM## //Number of base stations
1
##GPSBASEFILENAME## //Base station information file path
D:\Example\Projects\Base.epo
##BASENO## //Base station information file number
0

##BASECOORSYS## //Base station coordinate system number

0

##GPSBASEBLH## //Base station coordinates
39.902240822454 116.255306511586 73.317854203
##GPSBASEBLHWGS84## //Base station coordinates under WGS84
39.902240822454 116.255306511586 73.317854203
##BASEMODE## //Base station mode
0
##GPSBASEANTENNAH## //Base station antenna height and antenna radius
0.000000000000 0.000000000000
##ROVENUM## //Number of rover f
1
##ROVEFILENAME## //Rover information file path
D:\Example\Projects\Rover.epo
##GPSROVENO## //Rover information file number
0
##GPSROVEANTENNAH## //Rover antenna height and antenna radius
1.500000000000 0.089000000000

##OUTEVENTMARKFILENAME## //External event point file

##GNSSEPHEMERISFILENAME## //Precise ephemeris file path
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##GNSSCLKFILENAME## //Precision clock
##GNSSRESFILENAME## //GNSS positioning speed measurement

result file path

##OUTEVENTMARKFILENAME## //External event point file path

##WSFILENAME## //Odometer file path

##TSFILENAME## //Total station file path

##RSFILENAME## //RS file path

##IMUFILENAME## //IMU model and file path

0
D:\Example\Data\imu\pos_imu_3.imr
##PROCESS## //Project completion status identification
1
StaticMode //Static mode
0
KinematicMode //Dynamic mode
1
EllMask //Minimum height angle
15.000000
EllWeight //Height angle weight
0
ClockBiasRev //Receiver clock error compensation
0
EventTimeOffset //External event time offset
0.000000
LinearConstraint //Whether to use linear constraints
1
Quality //Precision quality control
0
SaveMidFile //Whether to save the intermediate result file
0
GPS CA Deviation //GPS C/A code standard deviation
0.250000
GPS L Deviation //GPS carrier phase standard deviation
0.000400
GLO CA Deviation //GLONASS C/A code standard deviation
9.000000
GLO L Deviation //GLONASS carrier phase standard deviation
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9.000000
BDS CA Deviation // BDS C/A code standard deviation
0.250000
BDS L Deviation // BDS carrier phase standard deviation
0.000400
SingleError //Single point positioning standard deviation

tolerance
300.000000
CADiffError //Code difference positioning standard

deviation tolerance
100.000000
LDiffError //Carrier phase differential positioning standard

deviation tolerance
0.100000
NDiffError //Ambiguity phase standard deviation tolerance
0.250000
DiffSateDpRange //Carrier phase positioning point difference

between static epochs
0.060000
DuelIonoError //Dual frequency ionospheric residual
0.060000
MaxGpsSateNum //Maximum GPS usage satellite number
8
MaxGloSateNum //Maximum number of satellites used by GLONASS
8
MaxCpsSateNum //Maximum BDS use satellite number
8
MinSegEpochNum //Segment minimum epoch
5
AmbGroupNum //Ambiguity search selected number of groups
100
RatioRange //Ambiguity resolution confidence
3.000000
NspaceK //Ambiguity search space factor
5.000000
DcomK //Dual frequency correlation absolute factor
0.20000
DcomBaseK //Dual frequency correlation linear factor
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0.000001
AmbDpRange //Code location estimation error
0.250000
IMUAxisRight // Right direction of the carrier corresponds

to the IMU axis
0
IMUAxisFront //Carrier forward corresponding IMU axial
2
IMUAxisUp //The carrier is oriented to the corresponding

IMU axis
4
GnssArmMeased //GNSS antenna to navigation center eccentricity

is used or not
1
ImuIntegratedRawData //IMU data is rate data or incremental data
0
NavFrame //Navigation coordinate system
0
ImuArmRight // IMU to navigation center vector in the right

component of the carrier
0.000000
ImuArmFront // IMU to navigation center vector in the forward

component of the carrier
0.000000
ImuArmUp // IMU to navigation center vector on the carrier
0.000000
GnssArmRight // GNSS to navigation center vector in the right

component of the carrier
-0.065000
GnssArmFront // GNSS to navigation center vector in the forward

component of the carrier
0.078000
GnssArmUp // GNSS to navigation center vector on the carrier
0.852000
AutoZUPT //Whether to use ZUPT
0
LeastZUPTV //ZUPT speed threshold
0.100000
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CoarseAlignTime //Coarse alignment time
10
UseGimbal //Whether to use the universal joint
0
UseVelocity //Whether to use GNSS velocity measurement as

Kalman filter observation
0
ForwardBackward //Whether to use round-trip filtering
1
Smoothing //Smoothing or not
0
NavDynInterval //Kalman filter status update interval
0.100000
NavMeasureInterval //Kalman filter measurement update interval
0.000000
NavSaveInterval //Result retention interval
0.020000
UseGyroSf //Whether to use the gyro scale factor as the

filter status
1
UseAcceSf //Whether to use the accelerometer scale factor

as the filter status
1
UseGnssLa //Whether to use GNSS antenna eccentricity as

the filter state
0
DXENU //Filter position initial standard deviation
0.50000000000000
0.50000000000000
1.00000000000000
DVENU //Filter speed initial standard deviation
0.30000000000000
0.30000000000000
1.00000000000000
DPRY //Filter attitude angle initial standard
deviation
1.00000000000000
1.00000000000000



Project Management

95

4.00000000000000
DGyrod //Filter gyro zero offset initial standard
deviation
1.00000000000000
1.00000000000000
1.00000000000000
DAcceb //Filter accelerometer zero offset initial standard

deviatio
1.00000000000000
1.00000000000000
1.00000000000000
DGyroK // Filter gyro scale factor initial standard deviation
0.00100000000000
0.00100000000000
0.00100000000000
DAcceK //Filter accelerometer scale factor initial

standard deviation
0.00100000000000
0.00100000000000
0.00100000000000
DGnssLa //Filter GNSS antenna eccentricity initial standard

deviation
0.10000000000000
0.10000000000000
0.10000000000000
XNoise //Filter position error power spectral density
0.00300000000000
0.00300000000000
0.00300000000000
VNoise //Filter speed error power spectral density
0.08000000000000
0.08000000000000
0.08000000000000
RNoise //Filter attitude angle error power spectral density
0.05000000000000
0.05000000000000
0.05000000000000
GyrodNoise //Filter gyro zero bias power spectral density
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0.80000000000000
0.80000000000000
0.80000000000000
AccebNoise //Filter accelerometer bias power spectral density
0.06000000000000
0.06000000000000
0.06000000000000
GyroKNoise //Filter gyro scale factor error power spectral density
0.00000100000000
0.00000100000000
0.00000100000000
AcceKNoise //Filter accelerometer scale factor error power

spectral density
0.00000100000000
0.00000100000000
0.00000100000000
GnssLaNoise //Filter GNSS antenna eccentricity error power

spectral density
0.00000000000000
0.00000000000000
0.00000000000000
Wheel Diameter //Wheel diameter
0.673200
Wheel Sensor Resolution //Odometer resolution
32.000000
Wheel Sensor LevelArm //The odometer to the navigation center is in

the right component of the carrier
0.651000

 Geosun format observation file "*.dat". When the user saves the

operation, the system will save the original observation file

information in the Geosun format, and each original observation file

will generate the .epo file with the same name.

 Position the attitude measurement solution file "<project

name>.pos". The file is saved to the project directory.
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 Customize the output file "*.txt". The system outputs the output

parameters in the specified template. By default, the output file is

saved to the project directory as "<project name>.txt". The data

format of the positioning attitude measurement output template is

as follows.

Project: D:\Example\Projects\Test.txt //Engineering path
Positioning Mode:24 //Processing mode
Input Base Datum: BaseNum: 1 //Number of base stations

BaseName: //Base station site name
FileName: Base Pos: 39.902240822 116.255306512 73.31785

Ant.Height:0.00000 //Base station file path, antenna height
Ant.Radius:0.00000 //Base station antenna radius

RoveNum: 1 //Number of rover stations

FileName: Ant.Height:0.00000 //Rover file path, antenna height
Ant.Radius:0.00000 //Rover antenna radius
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Appendix III: Shuttle File

Input and Output Format

 GNSS positioning speed measurement result

input format

 Positioning speed output format

 Positioning attitude output format

APPEND IX3
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GNSS positioning speed measurement result input format

The user can directly input the GNSS positioning speed measurement

without inputting the GNSS base station and the rover original file. At

this time, the GNSS/INS combined positioning speed measurement

operation can be performed, and the GNSS dynamic difference and

star selection operation cannot be performed.

The GNSS positioning speed measurement result file has a total of 14

columns of data, which are in order: GPS week, GPS week second,

latitude (deg), longitude (deg), elevation (m), eastward position

standard deviation (m), northbound position standard deviation (m),

elevation position standard deviation (m), eastward velocity (m/s),

northward velocity (m/s), skyward velocity (m/s), eastward velocity

standard deviation (m/s), northward direction Speed standard

deviation (m/s), standard deviation of sky speed (m/s), each column is

separated by space or Tab. The data is as follows:

1747 191827.04000 39.8642138761 116.2472904048 50.295 0.005 0.000
0.010 0.002 0.001 -0.010 0.003 0.000 0.003

1747 191827.06000 39.8642138762 116.2472904051 50.294 0.005 0.000
0.010 0.001 0.000 -0.009 0.003 0.000 0.003

1747 191827.08000 39.8642138581 116.2472904022 50.294 0.004 0.000
0.007 0.002 0.002 -0.010 0.002 0.000 0.002

1747 191827.10000 39.8642138593 116.2472904017 50.294 0.004 0.000
0.007 0.002 0.002 -0.010 0.002 0.000 0.002

1747 191827.12000 39.8642138595 116.2472904021 50.294 0.004 0.000
0.007 0.002 0.001 -0.010 0.002 0.000 0.002

Positioning speed output format

The positioning speed output template file output file contains the file

header and time, position, speed, standard deviation and other
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information, a total of 14 columns of data, in order: GPS week, GPS

week seconds, latitude (deg), longitude (deg), elevation (m),

eastbound standard deviation (m), northbound position standard

deviation (m), elevation position standard deviation (m), eastward

velocity (m/s), northward velocity (m/s), and skyward velocity ( m/s),

eastward speed standard deviation (m/s), northward speed standard

deviation (m/s), and natural velocity standard deviation (m/s), each

column is separated by a space or a Tab. The data is as follows:

Project: D:\Example\Projects\Test.txt
Positioning Mode:24
Input Base Datum: BaseNum: 1

BaseName:
FileName: Base Pos: 39.902240822 116.255306512 73.31785

Ant.Height:0.00000
Ant.Radius:0.00000

RoveNum: 1

FileName: Ant.Height:0.00000
Ant.Radius:0.00000

Positioning attitude output format

The positioning attitude output template output file contains the file

header and information such as time, position, speed, attitude,

standard deviation, etc. The file has 20 columns of data, which are in

order: GPS week, GPS week second, latitude (deg), longitude (deg) ),

elevation (m), eastward standard deviation (m), northbound position

standard deviation (m), elevation position standard deviation (m),

eastward velocity (m/s), northward velocity (m/s), day Speed (m/s),

eastward speed standard deviation (m/s), northward speed standard

deviation (m/s), skyward speed standard deviation (m/s), pitch angle
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(deg), roll angle ( Deg), heading angle (deg), pitch angle standard

deviation (deg), roll angle standard deviation (deg), heading angle

standard deviation (deg), and each column is separated by a space or

a Tab. The data is as follows:

Project: D:\Example\Projects\Test.txt
Positioning Mode:24
Input Base Datum: BaseNum: 1

BaseName:
FileName: Base Pos: 39.902240822 116.255306512 73.31785

Ant.Height:0.00000
Ant.Radius:0.00000

RoveNum: 1

FileName: Ant.Height:0.00000
Ant.Radius:0.00000
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Contact
Thank you for using GNSS/INS high-precision combined positioning

and attitude measurement system of Wuhan Geosun Navigation

Technology Co., Ltd, we will do our best to provide you with the best

technical support and service, thank you for your use!

Hot-line：400 0808 560

Wuhan Geosun Navigation Technology Co.,Ltd

Web：http://www.geosun-gnss.com.cn

Tel: +86-27-87504895

Fax: +86-27-87504895

e-mail: sales@geosun-gnss.com.cn

Add：4F, Building D, Maker Plaza No.8 West Maodianshan Road, East Lake

Hi-tech Zone Wuhan City, China

© All rights reserved by Wuhan Geosun Navigation Technology Co.,Ltd
Technical specifications are subject to change without notice.


